Python library import error with rpi_ws281x

Started by Smoin, June 25, 2022, 07:38:50 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi, this is my first post.
I am encountering an error and have no idea anymore why it is not working.
I installed the rpi_ws281x library via pip and when importing the package in an init script I get the following error:

script init_scene: Python error handler - Error line: 72 - Error object: <class 'ImportError'> - Error data: ImportError('/home/pi/GeeXLab_rpi32/libs//python/ undefined symbol: PyExc_SystemError')

(i just modified the system info demo script to also import this library)
I assume it has something to do with the library needing direct memory access but I am unsure on how to proceed.
Also as a sanity check I imported a different library the same way and it worked fine and I have tested on multiple devices.
If anyone has insights or experience with this topic please let me know.



Have you tried to import the package in command line to see if the error is present or not?
Something like:
$ python
import _rpi_ws281x as ws