GL-Z 0.5.0 released (Win64, Linux64 and Raspberry Pi)

Started by JeGX, October 04, 2019, 02:10:29 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


GL-Z has been updated for Linux to support GLIBC 2.23 (Ubuntu 16.04+).


Release notes:

Version - 2019/11/27
- Linux: updated with GLIBC 2.23 support + GeeXLab GeeXLab 0.29.7.


I'm using Raspberry Pi 4 with Raspberry Pi OS 64-bit.

I download GL-Z, uncompressed the zip, but am having trouble actually running it.

When doube-click GLZ, OS asks "this is an executable are you sure you want to execute it?"  I say Yes and nothing happens.

If I double click, I also have option to "run in terminal" - I try that, and the terminal opens but just sits there.

I tried from command line, "cd" to the directory I uncompressed GL-Z to.
Doing "./GLZ" says "no such file or directory" (even though LS lists it and shows as an executable)

I tried chmod u+x, but that shell script isn't running either.

Maybe this doesn't work for 64-bit?  Or was there some other package I needed to install?

EDIT:  cat /etc/os-release says...
Debian GNU/Linux 11 (bullseye)

Isn't that derived from Buster?


It's normal, GL-Z for Raspberry Pi has been compiled on the 32-bit version of the OS. It's not compatible with Raspberry Pi OS 64-bit. The only soft I compiled Raspberry Pi OS 64-bit is GeeXLab 0.46. I will try to update this tool as soon as I can...


I got the 8GB version of the Pi 4, which is only reason I did 64-bit OS. 

Do some transcoding and astronomy image stacking, while YT'ing - 8GB helps.

Thanks for the note, looking forward to 64-bit build of GL-Z someday!