Unable to run GeeXLab GLES 2.0 after updating to Raspbian "Stretch"!

Started by DarinM1967, October 02, 2017, 06:06:55 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


HW: Raspberry Pi 3
OS: Raspbian 2.1 (Sept. 2017 update)
SW: GeeXLab gles2.0 edition

Typing ./demo.sh for instance returns the following error:

./GeeXLab: error while loading shared libraries: libGLESv2.so: cannot open shared object file: No such file or directory

GeeXLab's OpenGL 2.1 works fine.

Pi3d was having the same error/issue and came to this conclusion:

In the most recent version of Raspbian, code name "Stretch", the non-open-source Broadcom OpenGLES 2.0 library was renamed from "libGLESv2.so" to "libbrcmGLESv2.so" and likewise "libEGL.so" was renamed to "libbrcmEGL.so", to avoid name clashes with the MESA library.

Which they resolved by making an update to their files and recompiled.  This issue is currently affecting Urho3d and AppGameKit 2 (AGK2).  Even though I do not use GeeXLab, I thought I'd let you all know what was going on in case anyone uses it with their Raspberry Pis.  Take care now,

Darin Murphy


Thank you Darin for your feedback. It's weird because I compiled and tested GeeXLab on Raspbian Stretch and I didn't see this issue. Anyway, I will update the OpenGL ES support for the next release. Thanks!


I ran into this issue using on a freshly installed raspbian "stretch" on my Pi3, using the raspberry pi-specific "control window opacity" example:

Darin's advice was correct.
I found the libbrcm*.so libraries in /opt/vc/lib/
and just symbolic linked them within GeeXLab's "dylibs" folder

which means I basically cd'd into dylibs, and ran:
ln -s /opt/vc/lib/libbrcmGLESv2.so  libGLESv2.so
ln -s /opt/vc/lib/libbrcmEGL.so  libEGL.so

(i might've also done the same for libbrcmWFC.so and libbrcmOpenVG.so, but I don't think those were needed here)


The support of Raspbian Stretch has been added in GeeXLab

The Raspbian Stretch version of GeeXLab can be downloaded from THIS PAGE. This version is directly linked to libbrcmGLESv2.so.  (I just noticed that the download link on the HackLab blog was wrong, it pointed at the Jessie version that is linked with libGLESv2.so).