How to quit??

Started by jpriede, August 08, 2017, 10:31:33 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


How do I close a GeeXLab demo run from the console? (Raspberry Pi) I ran the generic GeeXLab demo, and it covered part of my console with the spinning torus-knot at ~160fps... but it's stuck. I've tried:

CTRL-C, CTRL-X, ESC, q, Q, CTRL-Q, ALT-Q.. ALT-X.. enter.. space... mashing the keyboard... clicking the mouse... (I can see a cursor within the GeeXLab overlay window)

This seems like such a trivial question, but I've looked through the documentation and can't find any reference, nor any hint in the first tutorial, or any reference on this forum...


ESC should be enough to quit GeeXLab on RPi. Which GeeXLab have you tested? The OpenGL ES or the OpenGL 2.1 ?

I recommend you the OpenGL 2.1 version (it requires raspbian jessie) because it creates a real X11 window you can move and close like any other windows.


Hi JeGX,

At that moment I was using the ES version.
I went into X and tried both the OpenGL 2.1 and ES version, and had no issues quitting the programs.
It seems that sometimes, there is some glitch running GeeXLab ES from the console under some circumstances (I haven't narrowed it down specifically yet).
I ran the vertex pool OpenGL ES version at 1720x960 fullscreen mode and it ran fine, and esc closed the program no problem.
I ran the same demo at 1920x1080 fullscreen mode, and it was a solid white screen. ESC still closed it though.
I ran the same demo at 1919x1079 fullscreen mode, and no graphics came up, and ESC just added ^[ to my screeen. Pressing CTRL-Z stopped the demo.
I then ran the demo at 640x480 fullscreen mode, and no graphics came up, and ESC just added ^[ to my screen. CTRL-Z stopped the demo.
1280x720 non-full screen, same deal. No graphics, ESC made ^[, and CTRL-Z stopped it.
Then I rebooted the pi.
Ran the 1280x720 non-full screen, and it worked fine, except ESC does nothing, and CTRL-Z does nothing. The demo has a white mouse cursor which is responsive.
So, now the GeeXLab demo is running at 1280x720 non-fullscreen at 43FPS, I see the shell/terminal for the rest of my screen with:

- EGL_VENDOR: Broadcom
- GL_VENDOR: Broadcom
glGetError 0x500

Not sure what the glGetError 0x500 is, but it consistently comes up every time I run the demos, even if they work flawlessly and respond to ESC to quit so I'm not convinced that has anything to do with ESC key being ignored/unnoticed by GeeXLab in some state.


The 0x500 is an old error in the RPi version of GeeXLab. Since all demos work fine, I never took the time to fix it.  And indeed it has no relation with quit issue.

In the GL ES version, there is no window manager provided by Raspbian. I have had to code the low level keyboard and mouse management. That could explain why sometime for some reasons, GeeXLab does not respond correctly... The OpenGL 2.1 version does not have this issue because keyboard and mouse are managed by X11. I will try to improve input management of the GL ES version in one of the next updates.



In the mean-time, I'm just doing a workaround of going in via ssh from another computer, and killing the process if it happens. Much friendlier than a hard reboot on the Pi! :)