Author Topic: GLSL Hacker 0.8.5.2 available  (Read 6116 times)

0 Members and 1 Guest are viewing this topic.

JeGX

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1995
    • View Profile
    • Geeks3D.com
GLSL Hacker 0.8.5.2 available
« on: June 22, 2015, 09:20:20 PM »
A new update of GLSL Hacker is ready.

Download for Windows 64, Linux 64, OSX and Raspberry Pi here:
http://www.geeks3d.com/glslhacker/download/

Changelog:
http://www.geeks3d.com/glslhacker/changelog/


ShyPixie

  • Zombie
  • *
  • Posts: 1
    • View Profile
Re: GLSL Hacker 0.8.5.2 available
« Reply #1 on: August 26, 2015, 08:38:26 PM »
On Arch Linux the plugin_gxl_python_27_x64.so fails because I don't have a libpython2.7.so.1, only libpython2.7.so.1.0 and libpython2.7.so

Code: [Select]
2015:08:26@15:29:28(0000000012) <!> Python 2.7 installation not found: unable to load Python core library (libpython2.7.so.1).
2015:08:26@15:29:28(0000000013) <!> Unable to load plugin plugin_gxl_python_27_x64.so
« Last Edit: August 26, 2015, 08:40:45 PM by ShyPixie »

JeGX

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1995
    • View Profile
    • Geeks3D.com
Re: GLSL Hacker 0.8.5.2 available
« Reply #2 on: August 28, 2015, 07:42:47 PM »
I should link the Python plugin with something that is present on every linux distro like  libpython2.7.so. You can still try to copy the Python shared objects in the GLSL Hacker plugin dir and rename one of them in libpython2.7.so.1. That should work...

I will look at this issue for the next Linux update of GLSL Hacker.