Geeks3D Forums

GeeXLab => GeeXLab - english forum => Topic started by: Stefan on December 08, 2015, 06:10:52 AM

Title: Meditation for dummies vs. Intel graphics
Post by: Stefan on December 08, 2015, 06:10:52 AM
Found another shader not working properly with Intel graphics.

Original Shadertoy code (https://www.shadertoy.com/view/Md3GR4)

Ported to GeeXLab (https://drive.google.com/file/d/0BykQ4pHxfGQWQjVMdVhzVXVMLU0/view)

I'm using now the new scene scripts.
Also i found a lazy method to avoid editing the original Shadertoy code at all, just replace the commented line.

EDIT: main function optimized

  <raw_data_ps><![CDATA[
uniform vec3      iResolution;     
uniform float     iGlobalTime;     
uniform vec4      iMouse;         
// et cetera

/* replace this line with original code */

void main(){vec4 color = vec4(0.,0.,0.,1.);mainImage(color,gl_FragCoord.xy);gl_FragColor = color;} 


   ]]></raw_data_ps>



(https://farm1.staticflickr.com/621/23305196780_f69e21b80d_o.png)
Title: Re: Meditation for dummies vs. Intel graphics
Post by: Stefan on December 27, 2015, 10:58:42 AM
Found no fix for the demo yet, but i shortened the main function.

Also i added GPU vendor dependent messages as described in How to Check the Availability of an OpenGL Extension (http://www.geeks3d.com/hacklab/20150509/how-to-check-the-availability-of-an-opengl-extension/)

<script name="update_scene" run_mode="FRAME" >   

    local ret = gh_renderer.check_opengl_extension("GL_INTEL_performance_query")
    if (ret == 1) then
    gfx.write_text(10, 160, 1, 0, 0, 1, "Intel render issue")
    end
    local ret = gh_renderer.check_opengl_extension("GL_NVX_gpu_memory_info")
    if (ret == 1) then
    gfx.write_text(10, 160, 0, 1, 0, 1, "NVIDIA works fine")
    end
    local ret = gh_renderer.check_opengl_extension("GL_AMD_debug_output")
    if (ret == 1) then
    gfx.write_text(10, 160, 0, 1, 0, 1, "AMD works fine")
    end