Geeks3D Forums

GeeXLab => GeeXLab - english forum => Topic started by: JeGX on May 11, 2015, 08:31:30 PM

Title: GLSL Hacker 0.8.4
Post by: JeGX on May 11, 2015, 08:31:30 PM
This is the thread for feedback and bug reports of GLSL Hacker 0.8.4.x.

GLSL Hacker 0.8.4 story:
http://www.geeks3d.com/20150511/glsl-hacker-0-8-4-released-for-windows-linux-os-x-and-raspberry-pi/

Title: Re: GLSL Hacker 0.8.4
Post by: rostfrei on June 18, 2015, 08:43:14 AM
Hi,

I never used GLSL hacker so I'm not sure if I'm doing something wrong. I downloaded latest 64 bit windows version, extracted it and started GLSLHacker.exe. Nothing happens. No warning, error whatsoever. It just doesn't start. Then I tried to start it trough command prompt and still nothing.


C:\Program Files\GLSLHacker_win64>GLSLHacker.exe

C:\Program Files\GLSLHacker_win64>GLSLHacker.exe /?

C:\Program Files\GLSLHacker_win64>app_start_opengl_viewer.bat

C:\Program Files\GLSLHacker_win64>rem All command line parameters: http://www.geeks3d.com/forums/index.php/topic,3066.0.html

C:\Program Files\GLSLHacker_win64>start GLSLHacker.exe /demofile="apps/OpenGLViewer/gl-320-oglviewer_moon3d.xml"

C:\Program Files\GLSLHacker_win64>app_start_polygon_3d_object_viewer.bat

C:\Program Files\GLSLHacker_win64>rem All command line parameters: http://www.geeks3d.com/forums/index.php/topic,3066.0.html

C:\Program Files\GLSLHacker_win64>start GLSLHacker.exe /demofile="apps/Polygon3DViewer/polygon_gl3.xml"



What else can I do? How can I investigate further?

Br
Title: Re: GLSL Hacker 0.8.4
Post by: rostfrei on June 18, 2015, 08:56:29 AM
I found the answer in this thread http://www.geeks3d.com/forums/index.php/topic,3699.0.html. gumlym found the solution. plugin_gxl_python_27_x64.dll plugin causes this.

So which functionality will be limited without this plugin?

Br
Title: Re: GLSL Hacker 0.8.4
Post by: JeGX on June 18, 2015, 12:03:28 PM
The only limitation is that you won't be able to use Python in your demos. That's all. All features are available in Lua and Python so the Python plugin is not mandatory.

Now if you want to play with Python, you have to install the latest Python 2.7 64-bit :

- https://www.python.org/ftp/python/2.7.10/python-2.7.10.msi


I have to look at this issue in a near future...