Vulkan 1.2 Conformance for Raspberry Pi 4

Started by JeGX, August 04, 2022, 12:32:23 PM

Previous topic - Next topic

0 Members and 2 Guests are viewing this topic.

JeGX

QuoteFor the last couple of years, we have been working with our friends at Igalia to bring Vulkan to the Raspberry Pi 4 platform, and today we're happy to announce that we have achieved Vulkan 1.2 conformance from Khronos.

Raspberry Pi Ltd   2022-07-15   Vulkan_1_2 
Raspberry Pi 4 Model B
  CTS Version: 1.3.1.1
  CTS Version: 1.3.1
  Broadcom BCM2711, quad-core Cortex-A72 (ARM v8)
  OS: Raspbian Linux 5.10.92-v8 (aarch64)
  API version: 1.2.217
  GPU: VideoCore VI HW (V3D 4.2)

Link
- https://www.raspberrypi.com/news/vulkan-update-version-1-2-conformance-for-raspberry-pi-4/
- https://www.khronos.org/conformance/adopters/conformant-products#submission_694

I tested two days ago the Vulkan support on the RPi4 with GeeXLab and I will publish shortly a short article on that test.