Author Topic: Security Vulnerabilities Patched in recent AMD Radeon Adrenalin Drivers  (Read 1209 times)

0 Members and 1 Guest are viewing this topic.

JeGX

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2316
    • Geeks3D.com
It's a good opportunity to install latest Radeon Adrenalin 20.1.3.

- AMD ATI Radeon ATIDXX64.DLL shader functionality constant buffer denial-of-service vulnerability: CVE-2019-5124
Quote
An exploitable out-of-bounds read vulnerability exists in AMD ATIDXX64.DLL driver, version 26.20.13001.50005. A specially crafted pixel shader can cause a denial of service. An attacker can provide a specially crafted shader file to trigger this vulnerability. This vulnerability can be triggered from VMware guest, affecting VMware host.


- AMD ATI Radeon ATIDXX64.DLL MAD shader functionality denial-of-service vulnerability: CVE-2019-5146
Quote
An exploitable out-of-bounds read vulnerability exists in AMD ATIDXX64.DLL driver, version 26.20.13025.10004. A specially crafted pixel shader can cause a denial of service. An attacker can provide a specially crafted shader file to trigger this vulnerability. This vulnerability can be triggered from VMware guest, affecting VMware host.

- AMD ATI Radeon ATIDXX64.DLL MOVC shader functionality denial-of-service vulnerability: CVE-2019-5147
Quote
An exploitable out-of-bounds read vulnerability exists in AMD ATIDXX64.DLL driver, version 26.20.13003.1007. A specially crafted pixel shader can cause a denial of service. An attacker can provide a specially crafted shader file to trigger this vulnerability. This vulnerability can be triggered from VMware guest, affecting VMware host.


- AMD ATI Radeon ATIDXX64.DLL shader functionality VTABLE remote code execution vulnerability: CVE-2019-5183
Quote
An exploitable type confusion vulnerability exists in AMD ATIDXX64.DLL driver, versions 26.20.13031.10003, 26.20.13031.15006 and 26.20.13031.18002. A specially crafted pixel shader can cause a type confusion issue, leading to potential code execution. An attacker can provide a specially crafted shader file to trigger this vulnerability. This vulnerability can be triggered from VMware guest, affecting VMware host.

Links:
- via:
  https://www.techpowerup.com/263237/amd-quietly-patched-four-major-gpu-security-vulnerabilities-with-radeon-20-1-1-drivers

- AMD Product Security:
  https://www.amd.com/en/corporate/product-security