Author Topic: Vulkan SDK 1.0.49 Released  (Read 836 times)



0 Members and 1 Guest are viewing this topic.

Stefan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3979
    • View Profile
Vulkan SDK 1.0.49 Released
« on: May 19, 2017, 06:56:39 PM »
  This SDK supports Vulkan API revision 1.0.49.  The prior SDK supported Vulkan API revision 1.0.46.

Drivers: LunarG recommends that you update your Vulkan-capable hardware drivers to the latest recommended version from your hardware vendor.  A list of Known Driver Issues appears at the end of this document with more information.
SDK Libraries have moved -- As of the 1.0.42 SDK, the SDK library files were moved out of <VK_SDK_PATH>/bin into <VK_SDK_PATH>/lib for 64-bit libraries and <VK_SDK_PATH>/lib32 for 32-bit libraries. This will require you to update your project files to point to the proper location if you are updating from an older SDK.  The change was performed to avoid 32-bit compatibility issues.
Valid Usage ID Changes Coming -- Starting with the next major SDK release the valid usage identification numbers will be changed to accomodate the official valid usage ID management process, presumeably for the final time. If you are currently using these IDs to filter messages or for debugging purposes they will need to be remapped.

Stefan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3979
    • View Profile
Re: Vulkan SDK 1.0.49 Released
« Reply #1 on: May 19, 2017, 08:12:20 PM »
S.o. at NVIDIA has read the change log  :P

Quote
changes the way to look for Vulkan SDK
 
changes to adapt to the latest Vulkan SDK (essentially: the libs are in Lib folder now)