Author Topic: OpenGL Extension Viewer 3.13 available  (Read 2579 times)

0 Members and 1 Guest are viewing this topic.

Stefan

  • Global Moderator
  • Hero Member

  • Offline
  • *****

  • 2912
    • View Profile
OpenGL Extension Viewer 3.13 available
« on: July 28, 2009, 10:17:31 PM »
Quote
Here the list of changes

3.12    Added OpenGL 3.1 detection. Added OpenGL 3.0 renderer (windows only), Improved OpenGL 3.0 detection, added new renderers.
3.11    Update to GLEW 1.5.1. Added OpenGL 3.0 functions entry point. Fixed application issue with & characters in the monitor name (Windows version).
3.10    Added OpenGL 3.0 core features set.

Get it from Realtech.

Aks

  • Newbie

  • Offline
  • *

  • 2
    • View Profile
Re: OpenGL Extension Viewer 3.13 available
« Reply #1 on: July 29, 2009, 11:36:49 AM »
At last OpenGL Extension Viewer admits that there is OpenGL 3.1.  ;)
Thank you Stefan!

It will be nice if OpenGL Extension Viewer can change the way it verifies GLSL version on NVIDIA GPUs. Currently supported version of GLSL on my GPU is 1.40 NVIDIA via Cg compiler, but OpenGL Extension Viewer says that even ver. 1.10 is not supported.

There is one minor bug in section Rendering tests. Only test 3.0 can be executed, even if checkbox All is checked.

Nevertheless, Extension Viewer is great! Keep on, guys!

Stefan

  • Global Moderator
  • Hero Member

  • Offline
  • *****

  • 2912
    • View Profile
Re: OpenGL Extension Viewer 3.13 available
« Reply #2 on: July 29, 2009, 12:51:08 PM »
Yeah, it behaves a bit odd.
Change the renderer in the pull-down menu to "xxx/PCI/SSE2"
The developer explains it here:
http://www.realtech-vr.com/forums2/viewtopic.php?f=10&t=91

Aks

  • Newbie

  • Offline
  • *

  • 2
    • View Profile
Re: OpenGL Extension Viewer 3.13 available
« Reply #3 on: July 29, 2009, 04:32:10 PM »
It's OK! I have overlooked that drop-down menu (where, in fact, the rendering context parameters are defined). Naturally, if WGL_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB flag is set, nothing of deprecated functionality cannot be achieved. But that is not obvious for a naive user, like I was. ;)

Thanks!