Author Topic: 4pixels Compute Toolkit Workbench  (Read 2559 times)

0 Members and 1 Guest are viewing this topic.

Stefan

  • Global Moderator
  • Hero Member

  • Offline
  • *****

  • 2912
    • View Profile
4pixels Compute Toolkit Workbench
« on: February 01, 2011, 06:09:10 PM »
Quote
The 4pixels Compute Toolkit Workbench is a powerful rapid prototyping environment. All kernels supported by the CTK can easily be connected to data sources and data viewers. New kernels can be created by entering the OpenCLTM source code and defining inputs and outputs. Images, binary data
and audio streams are supported. All results are visible in real time.

They also offer some OpenGL/D3D/OpenCL demos.



nuninho1980

  • NewsPosters
  • Jr. Member

  • Offline
  • *

  • 87
    • View Profile
Re: 4pixels Compute Toolkit Workbench
« Reply #1 on: February 01, 2011, 08:49:45 PM »
I have GTX 480 w/ 266.58whql but I got error message ??? after run openCL demos running win 7 x64 except software CPU works fine. but I will try xp-xp3 x86.

Stefan

  • Global Moderator
  • Hero Member

  • Offline
  • *****

  • 2912
    • View Profile
Re: 4pixels Compute Toolkit Workbench
« Reply #2 on: February 01, 2011, 09:13:26 PM »
I have GTX 480 w/ 266.58whql but I got error message ??? after run openCL demos running win 7 x64 except software CPU works fine. but I will try xp-xp3 x86.

It ran fine for me on with either ATI/Win7 x64 or NVIDIA/Vista x64 rig.
Can you make a screenshot of the actual error message?

nuninho1980

  • NewsPosters
  • Jr. Member

  • Offline
  • *

  • 87
    • View Profile
Re: 4pixels Compute Toolkit Workbench
« Reply #3 on: February 02, 2011, 01:17:13 AM »
I can run these new samples on xp x86 (266.58whql) :D and got 190fps (1fps running CPU AMD x6 1055T but single core proccessed) w/ auto-scene on "raytrace" openCL. I got 230 fps (1.4fps) on ray casting openCL. :D
but I cannot have solution these samples on win7 but I can run to work fine samples opencl on nVidia GPU Computing SDK 3.2 on same OS. lool
« Last Edit: February 02, 2011, 01:19:51 AM by nuninho1980 »

nuninho1980

  • NewsPosters
  • Jr. Member

  • Offline
  • *

  • 87
    • View Profile
Re: 4pixels Compute Toolkit Workbench
« Reply #4 on: February 03, 2011, 02:19:51 AM »
I got error message because gpu was disabled for opencl. ;)
I ran "regedit" and edited from cpu to gpu opencl. (you remember - http://www.geeks3d.com/forums/index.php/topic,1959.0.html) :)