AMD Catalyst 14.9 Released for Windows and Linux




AMD Catalyst ascii logo

AMD has released the September 2014 edition of its Catalyst graphics driver. Catalyst 14.9 is available for Windows (in WHQL version) and for Linux.

Downloads

Windows Release Notes:

  • Support for the AMD Radeon R9 285
  • Performance improvements compared to Catalyst 14.4
  • AMD Eyefinity enhancements
  • New user controls for video color and display settings
  • AMD Mantle enhancements
  • AMD AM1 JPEG decoding acceleration

Linux Release Notes:

  • Support for the AMD Radeon R9 285
  • Ubuntu 14.04 support
  • RHEL 7.0 support
  • Install improvements

Catalyst 14.9 is an OpenGL 4.4 driver and exposes 289 extensions (GL=266 and WGL=23) for a Radeon R7 (A10-7850K) under Win8.1 64-bit. The complete list of all extensions is available in THIS ENTRY of the GPU Database.


AMD Catalyst CCC info

AMD Catalyst 14.9 - GPU Caps Viewer





15 thoughts on “AMD Catalyst 14.9 Released for Windows and Linux”

  1. John Smith

    Hallelujah! I need to reinstall windows and waited for new driver to install it clean.

  2. przemo_li

    Also this driver bring (at last) GLSL shader on-disk cache.

    Good for OpenGL.
    (And since Nvidia alredy have this, and Valve sponsor work in this regard for Mesa, it will greatly improve quality of OpenGL implementations on Linux 🙂 )

  3. przemo_li

    Oh, and AMD is cooking some HSA and full OpenCL in 14.50 FGLRX branch 🙂

  4. John Smith

    They did it. They’ve broken Vsync in OpenGL, catalyst doesn’t force VSYNC anymore. Fuck you AMD.

  5. John Smith

    At least it worked more or less fine in 14.6 with ePSXe+Pete’s OpenGL 2.9 and PPSSPP but now there is the only workaround I’ve found is to create game profile, then it seems work.

  6. tapcio

    It seems my comment whit link was not added…
    @John Smith
    Try to use my wrapper plugin called “PeteOpenGL2Tweak”, you can find it @ngemu forums.

  7. Void

    I Had to downgrade to 14.4, OpenGL applications completely broken, Depth Test not working, VSync either.

  8. John Smith

    Thabk you but ePSXe doesn’t start with this tweaker, after I run CDROM emulator just quits\disappear

  9. John Smith

    It seems, Win 8.1 Pro x64, Radeon 280X (ex 7970), Catalyst 14.9, Visual C++ redist installed, ePSXe 1.9 + Pete’s OpenGL 2.9 works good.

  10. John Smith

    maybe they’re going to add OpenGL 4.5 that’s why they made a lot of changes and broke some halfway…

  11. przemo_li

    There are already some big changes in new Catalyst (unofficial one).

    FGLRX stream 14.50 should be good.

    (Btw that number is different from Catalyst 14.X number!)

Comments are closed.