NVIDIA R296.10 WHQL Released, GeForce GTX 560 SE Support


NVIDIA logo


NVIDIA has just released a new WHQL certified graphics driver for all GeForce cards. R296.10 brings the support of GeForce GTX 560 SE, and installs PhysX System Software v9.12.0213. New SLI profiles as well as new 3D Vision support have been added (more details in the release notes).

R296.10 WHQL Downloads for Desktop

R296.10 WHQL Downloads for Notebooks



R296.10 is based on the r295_43-27 development branch and exposes OpenGL 4.2 API with 290 OpenGL extensions. The complete list of extensions is available HERE. R296.10 is also an OpenCL 1.1 driver.

NVIDIA R296.10, GPU Caps Viewer 1.15.1 and GTX 460
GPU Caps Viewer 1.15.1


8 thoughts on “NVIDIA R296.10 WHQL Released, GeForce GTX 560 SE Support”

  1. mirror

    I had all this time 260.99 and decided yesterday to upgrade to 293.75. Nvidia installer failed!
    ( win xp 32 – nvidia 450 ).
    removed and reinstalled, the same. clean install, the same. from safe mode, the same.

    Then started to revert: 285.xx version: same, unable to install, 280.xx the same. 273.xx the same. I could only install 270.61. I cannot install any driver past 270.61 all end with the same message: nvidia installer failed. tried the tricks from device manager to no success. And yes, i did neither install hd audio nor the nvidia updater. This is weird.

    What’s most enraging is that I cannot make an nvidia forums account because I can’t even pass the registration form: there is an error, please correct the highlighted field and guess what: there is no highlighted field!

  2. Psolord

    Alas, Alan Wake now runs quite good with SLI enabled. Problem is, one card is running at 99% load and the second card at 33%. Weird.

    I’ll check if it’s due to some cpu limit, but normally cpu limits do not manifest that way on the gpu loads.

  3. mirror

    @GPUToaster thanks for the tip, yes of course I tried it, I have tried also various other things ( like permissions to a registry key ) suggested from other users with the same problem but alas nothing worked.

    And also this last drivers 296.10 doesn’t also work.

  4. Corwin

    “also these last drivers 296.10 doesn’t also DON’T work*”

    try previous WHQL 295.73, it works good and has all that you need

  5. mirror

    thanks corvin, but just like i said in my first post, nothing past 270.61 drivers works for me 😀

Comments are closed.