[Graphics Drivers] ATI Catalyst 10.9 Available

Catalyst logo

Catalyst 10.9, Radeon HD 5870, GPU Caps Viewer

AMD has published the September 2010 edition of the Catalyst graphics drivers. Catalyst 10.9 is does not bring new features nor new OpenGL extensions. As usual, you can download Catalyst drivers HERE.

This version of Catalyst support all Radeon HD 2000. 3000, 4000 and 5000.

I quickly tested the OpenGL 4.0 tessellation performances in TessMark and they’re still the same (no drop, no boost, see the comparative table HERE).

Somne data from GPU Caps Viewer 1.9.0
– Drivers Version: 8.771.0.0 – Catalyst 10.9 (8-25-2010) – atig6pxx.dll
– ATI Catalyst Version String: 10.9
– ATI Catalyst Release Version String: 8.771-100825a-104558C-ATI
– OpenGL Version: 4.0.10188 Compatibility Profile/Debug Context
– GLSL (OpenGL Shading Language) Version: 4.00
– OpenGL Extensions (Radeon HD 5870): 204 extensions (GL=185 and WGL=19)



  • Pingback: ATI Catalyst 10.9a Hotfix - 3D Tech News, Pixel Hacking, Data Visualization and 3D Programming - Geeks3D.com

  • Hi JeGX and all viwers of this site,
    Plz help me!!!

    I have installed latest version of ATI catalyst
    i.e 10.9 in my laptop “Dell n4010” which have 1GB GDDR3 ATI Mobility 5470 graphics with Win 7 Home Premium 64bit.

    But i’m not able to use OpenGL 4,
    GPU Caps Viwer shows that it only Support OpenGL 3.2 though i’m able to use DirectX 11.

    JeGX stated in his website that OpenGL 4 is supported in ATI 5 series Graphics. So what is the problem. Why i’m not able to see OpenGL 4 support in caps viwer? Also Tess Mark is not running in my system.

  • Mobilty Radeon HD 5470 should support OpenGL 4. There is a result in TessMark comparative table with a mobility HD 5470. But it was with Cat 10.7. Maybe GL 4 support is not available in Cat 10.9 for HD 5470 due to a bug in the driver… or you need to resintall properly the drivers. I can’t help you more since I don’t have such a GPU.

  • Bergy

    I have 5870 and I got a lot of crashes with Cat 10.8 in Win 7 64-bit.

    I manually set higher fan speed, but that only helped to delay the crash, then I flashed newer BIOS and that didn’t helped either…

    Cat 10.8b fixed my problems. I didn’t found out why, but if someone might knew the answer pleas tell me, so I can avoid those crashes.

  • Stefan

    Actually the CAT 10.9 Mobile version has not been released yet.
    Failure with modified inf file?
    As i do i have a CEDAR 5470 i will make a forum post when it is available and make some tests.

  • Thank u JeGX and Stefan for replying me back.
    My problem is solved now, Actualy i was installing wrong driver that was for desktop
    GFX card.

    Now, i know that there is different driver exclusive for ATI Mobility GFX Card.
    that I found at


  • Stefan

    News from ATI’s programmer:

    “There is no Catalyst Mobility 10.9. Use 10.8, until 10.10 is ready”


  • Elvis

    Opengl4 problem:
    No OpenGL4 in any driver other than 10.3 opengl4 beta driver for anything X64 :(

    Is there a alternative way to get opengl4 back as it worked in CCC10.3 opengl4 x64 driver both xp x64 and win7 x64 and after updating to newer drivers it is missing.

    Ati 5870 Desktop, Ati 4830 Desktop, Ati 5750 mobile.

  • 6arrep

    catalyst 10.9
    Warning! Slave GPU doesn’t change 2D to 3D status (frequency) in games. That mean it slows all CrossFire GPU’s Perfomance to basic frequency.

  • Athlonite

    Meh I still don’t see the reason for limiting the global mem to 256MB for GL 512MB for CL hey ATI why did I bother buying an 1GB video card I coulda stuck with my old crap HD2600